What’s Vulnerable › Vulnerabilities

CVE-2025-26864: Apache IoTDB: Exposure of Sensitive Information in IoTDB OpenID Authentication

Description

Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in the OpenIdAuthorizer of Apache IoTDB. This issue affects Apache IoTDB: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2. Users are recommended to upgrade to version 1.3.4 and 2.0.2, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 1.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-26864 or the next vulnerability affects your stack