What’s Vulnerable › Vulnerabilities
CVE-2025-26909: WordPress Hide My WP Ghost plugin <= 5.4.01 - Local File Inclusion to RCE vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-98
Description
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in John Darrel Hide My WP Ghost hide-my-wp allows PHP Local File Inclusion.This issue affects Hide My WP Ghost: from n/a through <= 5.4.01.
Affected products
- johndarrel WP Ghost (Hide My WP Ghost) – Security & Firewall: before 5.4.02 — fixed in 5.4.02
How to fix
Upgrade to a fixed version: johndarrel WP Ghost (Hide My WP Ghost) – Security & Firewall 5.4.02. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26909 or the next vulnerability affects your stack