What’s Vulnerable › Vulnerabilities
CVE-2025-2691
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-23 · updated 2026-06-17
- Weakness: CWE-918
Description
Versions of the package nossrf before 1.0.4 are vulnerable to Server-Side Request Forgery (SSRF) where an attacker can provide a hostname that resolves to a local or reserved IP address space and bypass the SSRF protection mechanism.
Affected products
- nossrf: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: nossrf 1.0.4. Check the vendor advisory for mitigations.
References
- https://security.snyk.io/vuln/SNYK-JS-NOSSRF-9510842
- https://security.snyk.io/vuln/SNYK-JS-NOSSRF-9510842
Get alerted when CVE-2025-2691 or the next vulnerability affects your stack