What’s Vulnerable › Vulnerabilities
CVE-2025-2694: IBM Sterling B2B Integrator cross-site scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-10-18
- Weakness: CWE-79
Description
IBM Sterling B2B Integrator 6.0.0.0 through 6.1.2.7_1 and 6.2.0.0 through 6.2.0.4 and IBM Sterling File Gateway 6.0.0.0 through 6.1.2.7_1 and 6.2.0.0 through 6.2.0.4 is vulnerable to cross-site scripting. This vulnerability allows a privileged user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM Sterling B2B Integrator: from 6.0.0.0 before 6.1.2.7_2; from 6.2.0.0 before 6.2.0.5 — fixed in 6.1.2.7_2, 6.2.0.5
- IBM Sterling File Gateway: from 6.0.0.0 before 6.1.2.7_2; from 6.2.0.0 before 6.2.0.5 — fixed in 6.1.2.7_2, 6.2.0.5
How to fix
Upgrade to a fixed version: IBM Sterling B2B Integrator 6.1.2.7_2, 6.2.0.5; IBM Sterling File Gateway 6.1.2.7_2, 6.2.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2694 or the next vulnerability affects your stack