What’s Vulnerable › Vulnerabilities
CVE-2025-26963: WordPress ClickWhale plugin <= 2.4.3 - Cross Site Request Forgery (CSRF) to Settings Change vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-25 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in ClickWhale ClickWhale clickwhale allows Cross Site Request Forgery.This issue affects ClickWhale: from n/a through <= 2.4.3.
Affected products
- ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages 2.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26963 or the next vulnerability affects your stack