What’s Vulnerable › Vulnerabilities
CVE-2025-27018: Apache Airflow MySQL Provider: SQL injection in MySQL provider core function
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-19 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Airflow MySQL Provider: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow MySQL Provider 6.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/47254
- https://github.com/apache/airflow/pull/47255
- https://lists.apache.org/thread/m8ohgkwz4mq9njohf66sjwqjdy28gvzf
- http://www.openwall.com/lists/oss-security/2025/03/19/4
Get alerted when CVE-2025-27018 or the next vulnerability affects your stack