What’s Vulnerable › Vulnerabilities
CVE-2025-2703
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The built-in XY Chart plugin is vulnerable to a DOM XSS vulnerability. A user with Editor permissions is able to modify such a panel in order to make it execute arbitrary JavaScript.
Affected products
- Grafana: from 11.6.0 before 11.6.0+security-01; from 11.5.0 before 11.5.3+security-01; from 11.4.0 before 11.4.3+security-01; from 11.3.0 before 11.3.5+security-01; from 11.2.0 before 11.2.8+security-01 — fixed in 11.2.8+security-01, 11.3.5+security-01, 11.4.3+security-01, 11.5.3+security-01, 11.6.0+security-01
How to fix
Upgrade to a fixed version: Grafana 11.2.8+security-01, 11.3.5+security-01, 11.4.3+security-01, 11.5.3+security-01. Check the vendor advisory for mitigations.
References
- https://grafana.com/security/security-advisories/cve-2025-2703
- https://www.sonarsource.com/blog/data-in-danger-detecting-xss-in-grafana-cve-2025-2703/
Get alerted when CVE-2025-2703 or the next vulnerability affects your stack