What’s Vulnerable › Vulnerabilities
CVE-2025-27095: JumpServer has a Kubernetes Token Leak Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-266
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.8.0 and 3.10.18, an attacker with a low-privileged account can access the Kubernetes session feature and manipulate the kubeconfig file to redirect API requests to an external server controlled by the attacker. This allows the attacker to intercept and capture the Kubernetes cluster token. This can potentially allow unauthorized access to the cluster and compromise its security. This vulnerability is fixed in 4.8.0 and 3.10.18.
Affected products
- jumpserver: before 3.10.18; from 4.0.0 before 4.8.0 — fixed in 3.10.18, 4.8.0
How to fix
Upgrade to a fixed version: jumpserver 3.10.18, 4.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27095 or the next vulnerability affects your stack