What’s Vulnerable › Vulnerabilities
CVE-2025-27134: Privilege escalation in Joplin server via user patch endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-284
Description
Joplin is a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks. Prior to version 3.3.3, a privilege escalation vulnerability exists in the Joplin server, allowing non-admin users to exploit the API endpoint `PATCH /api/users/:id` to set the `is_admin` field to 1. The vulnerability allows malicious low-privileged users to perform administrative actions without proper authorization. This issue has been patched in version 3.3.3.
Affected products
- laurent22 joplin: before 3.3.3 — fixed in 3.3.3
How to fix
Upgrade to a fixed version: laurent22 joplin 3.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/laurent22/joplin/commit/12baa9827dac9da903f244c9f358e3deb264e228
- https://github.com/laurent22/joplin/security/advisories/GHSA-xj67-649m-3p8x
- https://github.com/laurent22/joplin/security/advisories/GHSA-xj67-649m-3p8x
Get alerted when CVE-2025-27134 or the next vulnerability affects your stack