What’s Vulnerable › Vulnerabilities

CVE-2025-27158: Acrobat Reader | Access of Uninitialized Pointer (CWE-824)

Description

Acrobat Reader versions 24.001.30225, 20.005.30748, 25.001.20428 and earlier are affected by an Access of Uninitialized Pointer vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30763, 24.001.30235; Adobe Acrobat DC 25.001.20432; Adobe Acrobat Reader 20.005.30763; Adobe Acrobat Reader 25.001.20432. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-27158 or the next vulnerability affects your stack