What’s Vulnerable › Vulnerabilities
CVE-2025-27166: InDesign Desktop | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-787
Description
InDesign Desktop versions ID20.1, ID19.5.2 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe InDesign Desktop: before 19.5.3; from 20.0 before 20.2 — fixed in 19.5.3, 20.2
How to fix
Upgrade to a fixed version: Adobe InDesign Desktop 19.5.3, 20.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27166 or the next vulnerability affects your stack