What’s Vulnerable › Vulnerabilities
CVE-2025-27167: Illustrator | Untrusted Search Path (CWE-426)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-426
Description
Illustrator versions 29.2.1, 28.7.4 and earlier are affected by an Untrusted Search Path vulnerability that might allow attackers to execute their own programs, access unauthorized data files, or modify configuration in unexpected ways. If the application uses a search path to locate critical resources such as programs, then an attacker could modify that search path to point to a malicious program, which the targeted application would then execute. The problem extends to any type of critical resource that the application trusts.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.5; from 29.0 before 29.3 — fixed in 28.7.5, 29.3
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.5, 29.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27167 or the next vulnerability affects your stack