What’s Vulnerable › Vulnerabilities
CVE-2025-27170: Illustrator | NULL Pointer Dereference (CWE-476)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-476
Description
Illustrator versions 29.2.1, 28.7.4 and earlier are affected by a NULL Pointer Dereference vulnerability that could result in an application denial-of-service. An attacker could exploit this vulnerability to crash the application, leading to a denial of service condition. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.5; from 29.0 before 29.3 — fixed in 28.7.5, 29.3
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.5, 29.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27170 or the next vulnerability affects your stack