What’s Vulnerable › Vulnerabilities
CVE-2025-27185: After Effects | NULL Pointer Dereference (CWE-476)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-476
Description
After Effects versions 25.1, 24.6.4 and earlier are affected by a NULL Pointer Dereference vulnerability that could result in an application denial-of-service. An attacker could exploit this vulnerability to crash the application, leading to a denial-of-service condition. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: before 24.6.5; from 25.0 before 25.2 — fixed in 24.6.5, 25.2
How to fix
Upgrade to a fixed version: Adobe After Effects 24.6.5, 25.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27185 or the next vulnerability affects your stack