What’s Vulnerable › Vulnerabilities
CVE-2025-27196: Premiere Pro | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-122
Description
Premiere Pro versions 25.1, 24.6.4 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Premiere: before 24.6.5; from 25.0 before 25.2 — fixed in 24.6.5, 25.2
How to fix
Upgrade to a fixed version: Adobe Premiere 24.6.5, 25.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27196 or the next vulnerability affects your stack