What’s Vulnerable › Vulnerabilities
CVE-2025-27197: Lightroom Desktop | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-787
Description
Lightroom Desktop versions 8.2 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Lightroom Classic: before 8.3 — fixed in 8.3
How to fix
Upgrade to a fixed version: Adobe Lightroom Classic 8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27197 or the next vulnerability affects your stack