What’s Vulnerable › Vulnerabilities
CVE-2025-27198: Photoshop Desktop | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-122
Description
Photoshop Desktop versions 25.12.1, 26.4.1 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Photoshop: from 25.0 before 25.12.2; from 26.0 before 26.5 — fixed in 25.12.2, 26.5
How to fix
Upgrade to a fixed version: Adobe Photoshop 25.12.2, 26.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27198 or the next vulnerability affects your stack