What’s Vulnerable › Vulnerabilities
CVE-2025-27212
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-04 · updated 2026-06-17
- Weakness: CWE-20
Description
An Improper Input Validation in certain UniFi Access devices could allow a Command Injection by a malicious actor with access to UniFi Access management network. Affected Products: UniFi Access Reader Pro (Version 2.14.21 and earlier) UniFi Access G2 Reader Pro (Version 1.10.32 and earlier) UniFi Access G3 Reader Pro (Version 1.10.30 and earlier) UniFi Access Intercom (Version 1.7.28 and earlier) UniFi Access G3 Intercom (Version 1.7.29 and earlier) UniFi Access Intercom Viewer (Version 1.3.20 and earlier) Mitigation: Update UniFi Access Reader Pro Version 2.15.9 or later Update UniFi Access G2 Reader Pro Version 1.11.23 or later Update UniFi Access G3 Reader Pro Version 1.11.22 or later Update UniFi Access Intercom Version 1.8.22 or later Update UniFi Access G3 Intercom Version 1.8.22 or later Update UniFi Access Intercom Viewer Version 1.4.39 or later
Affected products
- Ubiquiti Inc UniFi Access G2 Reader Pro: from 1.11.23 before 1.11.23 — fixed in 1.11.23
- Ubiquiti Inc UniFi Access G3 Intercom: from 1.8.22 before 1.8.22 — fixed in 1.8.22
- Ubiquiti Inc UniFi Access G3 Reader Pro: from 1.11.22 before 1.11.22 — fixed in 1.11.22
- Ubiquiti Inc UniFi Access Intercom: from 1.8.22 before 1.8.22 — fixed in 1.8.22
- Ubiquiti Inc UniFi Access Intercom Viewer: from 1.4.39 before 1.4.39 — fixed in 1.4.39
- Ubiquiti Inc UniFi Access Reader Pro: from 2.15.9 before 2.15.9 — fixed in 2.15.9
How to fix
Upgrade to a fixed version: Ubiquiti Inc UniFi Access G2 Reader Pro 1.11.23; Ubiquiti Inc UniFi Access G3 Intercom 1.8.22; Ubiquiti Inc UniFi Access G3 Reader Pro 1.11.22; Ubiquiti Inc UniFi Access Intercom 1.8.22; Ubiquiti Inc UniFi Access Intercom Viewer 1.4.39; Ubiquiti Inc UniFi Access Reader Pro 2.15.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27212 or the next vulnerability affects your stack