What’s Vulnerable › Vulnerabilities

CVE-2025-27215

Description

An Improper Access Control could allow a malicious actor authenticated in the API of certain UniFi Connect Display Cast devices to make unsupported changes to the system. Affected Products: UniFi Connect Display Cast (Version 1.10.3 and earlier) UniFi Connect Display Cast Pro (Version 1.0.89 and earlier) UniFi Connect Display Cast Lite (Version 1.0.3 and earlier) Mitigation: Update UniFi Connect Display Cast to Version 1.10.7 or later Update UniFi Connect Display Cast Pro to Version 1.0.94 or later Update UniFi Connect Display Cast Lite to Version 1.1.8 or later

Affected products

How to fix

Upgrade to a fixed version: Ubiquiti Inc UniFi Connect Display Cast 1.10.7; Ubiquiti Inc UniFi Connect Display Cast Lite 1.1.8; Ubiquiti Inc UniFi Connect Display Cast Pro 1.0.94. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-27215 or the next vulnerability affects your stack