What’s Vulnerable › Vulnerabilities
CVE-2025-27219
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-770
Description
In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.
Affected products
- ruby-lang CGI: before 0.3.5.1; from 0.4.0 before 0.4.2; 0.3.6 — fixed in 0.3.5.1, 0.4.2
How to fix
Upgrade to a fixed version: ruby-lang CGI 0.3.5.1, 0.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2025-27219.yml
- https://hackerone.com/reports/2936778
- https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html
Get alerted when CVE-2025-27219 or the next vulnerability affects your stack