What’s Vulnerable › Vulnerabilities
CVE-2025-27221
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-212
Description
In the URI gem before 1.0.3 for Ruby, the URI handling methods (URI.join, URI#merge, URI#+) have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host.
Affected products
- ruby-lang URI: before 0.11.3; from 0.12.0 before 0.12.4; from 0.13.0 before 0.13.2; from 1.0.0 before 1.0.3 — fixed in 0.11.3, 0.12.4, 0.13.2, 1.0.3
How to fix
Upgrade to a fixed version: ruby-lang URI 0.11.3, 0.12.4, 0.13.2, 1.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/uri/CVE-2025-27221.yml
- https://hackerone.com/reports/2957667
- https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00015.html
Get alerted when CVE-2025-27221 or the next vulnerability affects your stack