What’s Vulnerable › Vulnerabilities
CVE-2025-27367: IBM OpenPages with Watson improper input validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-602
Description
IBM OpenPages with Watson 8.3 and 9.0 is vulnerable to improper input validation due to bypassing of client-side validation for the data types and requiredness of fields for GRC Objects when an authenticated user sends a specially crafted payload to the server allowing for data to be saved without storing the required fields.
Affected products
- IBM OpenPages with Watson: from 8.3 before 8.3.0.3.2; from 9.0 before 9.0.0.5.3 — fixed in 8.3.0.3.2, 9.0.0.5.3
How to fix
Upgrade to a fixed version: IBM OpenPages with Watson 8.3.0.3.2, 9.0.0.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27367 or the next vulnerability affects your stack