What’s Vulnerable › Vulnerabilities
CVE-2025-27371
- Severity: medium (CVSS 6.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-03 · updated 2026-06-17
- Weakness: CWE-305
Description
In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience values of JWTs sent to authorization servers. The affected RFCs may include RFC 7523, and also RFC 7521, RFC 7522, RFC 9101 (JAR), and RFC 9126 (PAR).
Affected products
- IETF RFC 7523: 7523
References
- https://eprint.iacr.org/2025/629
- https://github.com/OWASP/ASVS/issues/2678
- https://openid.net/notice-of-a-security-vulnerability/
- https://openid.net/wp-content/uploads/2025/01/OIDF-Responsible-Disclosure-Notice-on-Security-Vulnerability-for-private_key_jwt.pdf
- https://talks.secworkshop.events/osw2025/talk/R8D9BS/
Get alerted when CVE-2025-27371 or the next vulnerability affects your stack