What’s Vulnerable › Vulnerabilities
CVE-2025-27423: Improper Input Validation in Vim
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-03 · updated 2026-06-17
- Weakness: CWE-77
Description
Vim is an open source, command line text editor. Vim is distributed with the tar.vim plugin, that allows easy editing and viewing of (compressed or uncompressed) tar files. Starting with 9.1.0858, the tar.vim plugin uses the ":read" ex command line to append below the cursor position, however the is not sanitized and is taken literally from the tar archive. This allows to execute shell commands via special crafted tar archives. Whether this really happens, depends on the shell being used ('shell' option, which is set using $SHELL). The issue has been fixed as of Vim patch v9.1.1164
Affected products
- NetApp Hci Compute Node: all versions
- vim/vim: from 9.1.0858 before 9.1.1164 — fixed in 9.1.1164
How to fix
Upgrade to a fixed version: vim/vim 9.1.1164. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/129a8446d23cd9cb4445fcfea259cba5e0487d29
- https://github.com/vim/vim/commit/334a13bff78aa0ad206bc436885f63e3a0bab399
- https://github.com/vim/vim/security/advisories/GHSA-wfmf-8626-q3r3
- https://security.netapp.com/advisory/ntap-20250502-0002/
Get alerted when CVE-2025-27423 or the next vulnerability affects your stack