What’s Vulnerable › Vulnerabilities
CVE-2025-27440: Zoom Apps - Heap-based Buffer Overflow
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-124
Description
Heap overflow in some Zoom Workplace Apps may allow an authenticated user to conduct an escalation of privilege via network access.
Affected products
- Zoom Meeting Software Development Kit: before 6.3.0 — fixed in 6.3.0
- Zoom Video Communications, Inc. Zoom Rooms for Windows: before 6.3.0 — fixed in 6.3.0
- Zoom Rooms Controller: before 6.3.0 — fixed in 6.3.0
- Zoom Workplace: before 6.3.0 — fixed in 6.3.0
- Zoom Communications, Inc Zoom Workplace Desktop App for macOS: before 6.3.0 — fixed in 6.3.0
- Zoom Communications Zoom Workplace VDI Plugin: before 6.1.16; from 6.1.17 before 6.2.12 — fixed in 6.1.16, 6.2.12
How to fix
Upgrade to a fixed version: Zoom Meeting Software Development Kit 6.3.0; Zoom Video Communications, Inc. Zoom Rooms for Windows 6.3.0; Zoom Rooms Controller 6.3.0; Zoom Workplace 6.3.0; Zoom Communications, Inc Zoom Workplace Desktop App for macOS 6.3.0; Zoom Communications Zoom Workplace VDI Plugin 6.1.16, 6.2.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27440 or the next vulnerability affects your stack