What’s Vulnerable › Vulnerabilities
CVE-2025-27494
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability has been identified in SiPass integrated AC5102 (ACC-G2) (All versions < V6.4.9), SiPass integrated ACC-AP (All versions < V6.4.9). Affected devices improperly sanitize input for the pubkey endpoint of the REST API. This could allow an authenticated remote administrator to escalate privileges by injecting arbitrary commands that are executed with root privileges.
Affected products
- Siemens Sipass Integrated Ac5102 (Acc-G2) Firmware: before 6.4.9 — fixed in 6.4.9
- Siemens Sipass Integrated Acc-Ap Firmware: before 6.4.9 — fixed in 6.4.9
How to fix
Upgrade to a fixed version: Siemens Sipass Integrated Ac5102 (Acc-G2) Firmware 6.4.9; Siemens Sipass Integrated Acc-Ap Firmware 6.4.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27494 or the next vulnerability affects your stack