What’s Vulnerable › Vulnerabilities
CVE-2025-27505: GeoServer Missing Authorization on REST API Index
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-862
Description
GeoServer is an open source server that allows users to share and edit geospatial data. It is possible to bypass the default REST API security and access the index page. The REST API security handles rest and its subpaths but not rest with an extension (e.g., rest.html). The REST API index can disclose whether certain extensions are installed. This vulnerability is fixed in 2.26.3 and 2.25.6. As a workaround, in ${GEOSERVER_DATA_DIR}/security/config.xml, change the paths for the rest filter to /rest.*,/rest/** and change the paths for the gwc filter to /gwc/rest.*,/gwc/rest/** and restart GeoServer.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.25.6; from 2.26.0 before 2.26.3 — fixed in 2.25.6, 2.26.3
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.25.6, 2.26.3. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/pull/8170
- https://github.com/geoserver/geoserver/security/advisories/GHSA-h86g-x8mm-78m5
- https://osgeo-org.atlassian.net/browse/GEOS-11664
- https://osgeo-org.atlassian.net/browse/GEOS-11776
Get alerted when CVE-2025-27505 or the next vulnerability affects your stack