What’s Vulnerable › Vulnerabilities
CVE-2025-27506: NocoDB Vulnerable to Reflected Cross-Site Scripting on Reset Password Page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
NocoDB is software for building databases as spreadsheets. The API endpoint related to the password reset function is vulnerable to Reflected Cross-Site-Scripting. The endpoint /api/v1/db/auth/password/reset/:tokenId is vulnerable to Reflected Cross-Site-Scripting. The flaw occurs due to implementation of the client-side template engine ejs, specifically on file resetPassword.ts where the template is using the insecure function “<%-“, which is rendered by the function renderPasswordReset. This vulnerability is fixed in 0.258.0.
Affected products
- nocodb: before 0.258.0 — fixed in 0.258.0
How to fix
Upgrade to a fixed version: nocodb 0.258.0. Check the vendor advisory for mitigations.
References
- https://github.com/nocodb/nocodb/blob/ba5a191b33259d984fc92df225f7d82ede2ddb56/packages/nocodb/src/modules/auth/auth.controller.ts#L251
- https://github.com/nocodb/nocodb/blob/ba5a191b33259d984fc92df225f7d82ede2ddb56/packages/nocodb/src/modules/auth/ui/auth/resetPassword.ts#L71
- https://github.com/nocodb/nocodb/commit/ea821edb133e621e26183ae65c8ff9ee5d6f2723
- https://github.com/nocodb/nocodb/security/advisories/GHSA-wf6c-hrhf-86cw
Get alerted when CVE-2025-27506 or the next vulnerability affects your stack