What’s Vulnerable › Vulnerabilities
CVE-2025-27509: SAML authentication vulnerability due to improper SAML response validation
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-06 · updated 2026-06-17
- Weakness: CWE-285
Description
fleetdm/fleet is an open source device management, built on osquery. In vulnerable versions of Fleet, an attacker could craft a specially-formed SAML response to forge authentication assertions, provision a new administrative user account if Just-In-Time (JIT) provisioning is enabled, or create new accounts tied to forged assertions if f MDM enrollment is enabled. This vulnerability is fixed in 4.64.2, 4.63.2, 4.62.4, and 4.58.1.
Affected products
- fleetdm fleet: from 4.64.0, < 4.64.2; from 4.63.0, < 4.63.2; from 4.62.0, < 4.62.4; before 4.58.1
References
- https://github.com/fleetdm/fleet/commit/718c95e47ad010ad6b8ceb3f3460e921fbfc53bb
- https://github.com/fleetdm/fleet/security/advisories/GHSA-52jx-g6m5-h735
Get alerted when CVE-2025-27509 or the next vulnerability affects your stack