What’s Vulnerable › Vulnerabilities
CVE-2025-27511: GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-10-06
- Weakness: CWE-74
Description
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.27.0 of the GeoServer DB2 DataStore Extension, an administrator can perform a JNDI attack through specially crafted DB2 jdbc url leading to to Remote Code Execution (RCE). Version 2.27.0 fixes the issue.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.27.0 — fixed in 2.27.0
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/releases/tag/2.27.0
- https://github.com/geoserver/geoserver/security/advisories/GHSA-g628-r368-6vh7
- https://nvd.nist.gov/vuln/detail/cve-2023-27867
- https://osgeo-org.atlassian.net/browse/GEOT-7725
Get alerted when CVE-2025-27511 or the next vulnerability affects your stack