What’s Vulnerable › Vulnerabilities
CVE-2025-27531: Apache InLong: An arbitrary file read vulnerability for JDBC
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-06 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 before 2.1.0, this issue would allow an authenticated attacker to read arbitrary files by double writing the param. Users are recommended to upgrade to version 2.1.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache InLong: from 1.13.0 before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache InLong 2.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/r62lkqrr739wvcb60j6ql6q63rh4bxx5
- http://www.openwall.com/lists/oss-security/2025/02/28/2
Get alerted when CVE-2025-27531 or the next vulnerability affects your stack