What’s Vulnerable › Vulnerabilities

CVE-2025-27533: Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation

Description

Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ. During unmarshalling of OpenWire commands the size value of buffers was not properly validated which could lead to excessive memory allocation and be exploited to cause a denial of service (DoS) by depleting process memory, thereby affecting applications and services that rely on the availability of the ActiveMQ broker when not using mutual TLS connections. This issue affects Apache ActiveMQ: from 6.0.0 before 6.1.6, from 5.18.0 before 5.18.7, from 5.17.0 before 5.17.7, before 5.16.8. ActiveMQ 5.19.0 is not affected. Users are recommended to upgrade to version 6.1.6+, 5.19.0+, 5.18.7+, 5.17.7, or 5.16.8 or which fixes the issue. Existing users may implement mutual TLS to mitigate the risk on affected brokers.

Affected products

How to fix

Upgrade to a fixed version: Apache ActiveMQ 5.16.8, 5.17.7, 5.18.7, 6.1.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-27533 or the next vulnerability affects your stack