What’s Vulnerable › Vulnerabilities

CVE-2025-27538: MFA Enforcement Bypass Allows Unauthorized Removal of MFA for Other Users

Description

Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to enforce MFA checks in PUT /api/v4/users/user-id/mfa when the requesting user differs from the target user ID, which allows users with edit_other_users permission to activate or deactivate MFA for other users, even if those users have not set up MFA.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.2, 9.11.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-27538 or the next vulnerability affects your stack