What’s Vulnerable › Vulnerabilities
CVE-2025-27553: Apache Commons VFS: Possible path traversal issue when using NameScope.DESCENDENT
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-23 · updated 2026-06-17
- Weakness: CWE-23
Description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0. The FileObject API in Commons VFS has a 'resolveFile' method that takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of the base file". However, when the path contains encoded ".." characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not a descendent of the base file, without throwing an exception. This issue affects Apache Commons VFS: before 2.10.0. Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons VFS: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons VFS 2.10.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/cnzqowyw9r2pl263cylmxhnvh41hyjcb
- http://www.openwall.com/lists/oss-security/2025/03/23/1
- https://lists.debian.org/debian-lts-announce/2025/04/msg00006.html
Get alerted when CVE-2025-27553 or the next vulnerability affects your stack