What’s Vulnerable › Vulnerabilities
CVE-2025-2759: GStreamer Incorrect Permission Assignment Local Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-732
Description
GStreamer Incorrect Permission Assignment Local Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of GStreamer. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the product installer. The issue results from incorrect permissions on folders. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of a target user. Was ZDI-CAN-25448.
Affected products
- GStreamer: before 1.25.1 — fixed in 1.25.1
How to fix
Upgrade to a fixed version: GStreamer 1.25.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2759 or the next vulnerability affects your stack