What’s Vulnerable › Vulnerabilities
CVE-2025-27600: FastGPT SSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-06 · updated 2026-06-17
- Weakness: CWE-918
Description
FastGPT is a knowledge-based platform built on the LLMs. Since the web crawling plug-in does not perform intranet IP verification, an attacker can initiate an intranet IP request, causing the system to initiate a request through the intranet and potentially obtain some private data on the intranet. This issue is fixed in 4.9.0.
Affected products
- labring FastGPT: before 4.9.0 — fixed in 4.9.0
How to fix
Upgrade to a fixed version: labring FastGPT 4.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27600 or the next vulnerability affects your stack