What’s Vulnerable › Vulnerabilities
CVE-2025-27601: Umbraco Allows Improper API Access Control to Low-Privilege Users to Data Type Functionality
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-285
Description
Umbraco is a free and open source .NET content management system. An improper API access control issue has been identified Umbraco's API management package prior to versions 15.2.3 and 14.3.3, allowing low-privilege, authenticated users to create and update data type information that should be restricted to users with access to the settings section. The issue is patched in versions 15.2.3 and 14.3.3. No known workarounds are available.
Affected products
- Umbraco-CMS: before 14.3.3; from 15.0.0 before 15.2.3 — fixed in 14.3.3, 15.2.3
How to fix
Upgrade to a fixed version: Umbraco-CMS 14.3.3, 15.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/umbraco/Umbraco-CMS/commit/d9fb6df16e9adf8656181cac8497fc5ba23321cd
- https://github.com/umbraco/Umbraco-CMS/commit/ebb6a580dc1da2c772a99838dc7b4660bf77eb9c
- https://github.com/umbraco/Umbraco-CMS/security/advisories/GHSA-6ffg-mjg7-585x
Get alerted when CVE-2025-27601 or the next vulnerability affects your stack