What’s Vulnerable › Vulnerabilities
CVE-2025-27608: Self Cross-Site Scripting in Arduino IDE
- Severity: low (CVSS 1.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Arduino IDE 2.x is an IDE based on the Theia IDE framework and built with Electron. A Self Cross-Site Scripting (XSS) vulnerability has been identified within the Arduino-IDE prior to version v2.3.5. The vulnerability occurs in the Additional Board Manager URLs field, which can be found in the Preferences -> Settings section of the Arduino IDE interface. In the vulnerable versions, any values entered in this field are directly displayed to the user through a notification tooltip object, without a proper output encoding routine, due to the underlying ElectronJS engine interpretation. This vulnerability exposes the input parameter to Self-XSS attacks, which may lead to security risks depending on where the malicious payload is injected. This vulnerability is fixed in 2.3.5.
Affected products
- arduino-ide: before 2.3.5
References
- https://github.com/arduino/arduino-ide/commit/d298b3ffc94008e89066cd999d891e84190da18f
- https://github.com/arduino/arduino-ide/security/advisories/GHSA-252h-4j5q-88pc
Get alerted when CVE-2025-27608 or the next vulnerability affects your stack