What’s Vulnerable › Vulnerabilities
CVE-2025-27614: Gitk allows arbitrary command execution
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-78
Description
Gitk is a Tcl/Tk based Git history browser. Starting with 2.41.0, a Git repository can be crafted in such a way that with some social engineering a user who has cloned the repository can be tricked into running any script (e.g., Bourne shell, Perl, Python, ...) supplied by the attacker by invoking gitk filename, where filename has a particular structure. The script is run with the privileges of the user. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.
Affected products
- j6t gitk: from 2.41.0, < 2.43.7; from 2.44.0, < 2.44.4; from 2.45.0, < 2.45.4; from 2.46.0, < 2.46.4; from 2.47.0, < 2.47.3; from 2.48.0, < 2.48.2
References
- https://github.com/j6t/gitk/commit/8e3070aa5e331be45d4d03e3be41f84494fce129
- https://github.com/j6t/gitk/security/advisories/GHSA-g4v5-fjv9-mhhc
- http://www.openwall.com/lists/oss-security/2025/07/08/4
Get alerted when CVE-2025-27614 or the next vulnerability affects your stack