What’s Vulnerable › Vulnerabilities
CVE-2025-27617: Pimcore Vulnerable to SQL Injection in getRelationFilterCondition
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore is an open source data and experience management platform. Prior to version 11.5.4, authenticated users can craft a filter string used to cause a SQL injection. Version 11.5.4 fixes the issue.
Affected products
- pimcore/pimcore: before 11.5.4 — fixed in 11.5.4
How to fix
Upgrade to a fixed version: pimcore/pimcore 11.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/blob/c721a42c23efffd4ca916511ddb969598d302396/models/DataObject/ClassDefinition/Data/Extension/RelationFilterConditionParser.php#L29-L47
- https://github.com/pimcore/pimcore/blob/c721a42c23efffd4ca916511ddb969598d302396/models/DataObject/ClassDefinition/Data/Multiselect.php#L332-L347
- https://github.com/pimcore/pimcore/commit/19a8520895484e68fd254773e32476565d91deea
- https://github.com/pimcore/pimcore/security/advisories/GHSA-qjpx-5m2p-5pgh
Get alerted when CVE-2025-27617 or the next vulnerability affects your stack