What’s Vulnerable › Vulnerabilities
CVE-2025-27623
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-05 · updated 2026-06-17
- Weakness: CWE-312
Description
Jenkins 2.499 and earlier, LTS 2.492.1 and earlier does not redact encrypted values of secrets when accessing `config.xml` of views via REST API or CLI, allowing attackers with View/Read permission to view encrypted values of secrets.
Affected products
- Jenkins: before 2.492.2; before 2.500 — fixed in 2.492.2, 2.500
How to fix
Upgrade to a fixed version: Jenkins 2.492.2, 2.500. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27623 or the next vulnerability affects your stack