What’s Vulnerable › Vulnerabilities

CVE-2025-27624

Description

A cross-site request forgery (CSRF) vulnerability in Jenkins 2.499 and earlier, LTS 2.492.1 and earlier allows attackers to have users toggle their collapsed/expanded status of sidepanel widgets (e.g., Build Queue and Build Executor Status widgets).

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.492.2, 2.500. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-27624 or the next vulnerability affects your stack