What’s Vulnerable › Vulnerabilities
CVE-2025-27637
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Vasion Print (formerly PrinterLogic) before Virtual Appliance Host 22.0.1002 Application 20.0.2614 allows Cross-Site Scripting V-2024-016.
Affected products
- PrinterLogic Vasion Print: before 20.0.2614 — fixed in 20.0.2614
- PrinterLogic Virtual Appliance: before 22.0.1002 — fixed in 22.0.1002
How to fix
Upgrade to a fixed version: PrinterLogic Vasion Print 20.0.2614; PrinterLogic Virtual Appliance 22.0.1002. Check the vendor advisory for mitigations.
References
- https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html
- http://seclists.org/fulldisclosure/2025/Apr/18
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#va-xss-01
Get alerted when CVE-2025-27637 or the next vulnerability affects your stack