What’s Vulnerable › Vulnerabilities
CVE-2025-27696: Apache Superset: Incorrect authorization leading to resource ownership takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
Affected products
- Apache Superset: before 4.1.2 — fixed in 4.1.2
How to fix
Upgrade to a fixed version: Apache Superset 4.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413
- http://www.openwall.com/lists/oss-security/2025/05/12/3
Get alerted when CVE-2025-27696 or the next vulnerability affects your stack