What’s Vulnerable › Vulnerabilities
CVE-2025-27788: Ruby JSON Parser has Out-of-bounds Read
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-125
Description
JSON is a JSON implementation for Ruby. Starting in version 2.10.0 and prior to version 2.10.2, a specially crafted document could cause an out of bound read, most likely resulting in a crash. Versions prior to 2.10.0 are not vulnerable. Version 2.10.2 fixes the problem. No known workarounds are available.
Affected products
- ruby-lang Javascript Object Notation: from 2.10.0 before 2.10.2 — fixed in 2.10.2
How to fix
Upgrade to a fixed version: ruby-lang Javascript Object Notation 2.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/ruby/json/commit/c56db31f800d5d508389793e69682f99749dbadf
- https://github.com/ruby/json/releases/tag/v2.10.2
- https://github.com/ruby/json/security/advisories/GHSA-9m3q-rhmv-5q44
Get alerted when CVE-2025-27788 or the next vulnerability affects your stack