What’s Vulnerable › Vulnerabilities
CVE-2025-27789: Inefficient RexExp complexity in generated code with .replace when transpiling named capturing groups
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-1333
Description
Babel is a compiler for writing next generation JavaScript. When using versions of Babel prior to 7.26.10 and 8.0.0-alpha.17 to compile regular expression named capturing groups, Babel will generate a polyfill for the `.replace` method that has quadratic complexity on some specific replacement pattern strings (i.e. the second argument passed to `.replace`). Generated code is vulnerable if all the following conditions are true: Using Babel to compile regular expression named capturing groups, using the `.replace` method on a regular expression that contains named capturing groups, and the code using untrusted strings as the second argument of `.replace`. This problem has been fixed in `@babel/helpers` and `@babel/runtime` 7.26.10 and 8.0.0-alpha.17. It's likely that individual users do not directly depend on `@babel/helpers`, and instead depend on `@babel/core` (which itself depends on `@babel/helpers`). Upgrading to `@babel/core` 7.26.10 is not required, but it guarantees use of a new enough `@babel/helpers` version. Note that just updating Babel dependencies is not enough; one will also need to re-compile the code. No known workarounds are available.
Affected products
- Npm @Babel/Helpers: before 7.26.10; from 8.0.0-alpha.0 before 8.0.0-alpha.17 — fixed in 7.26.10, 8.0.0-alpha.17
- Npm @Babel/Runtime: before 7.26.10; from 8.0.0-alpha.0 before 8.0.0-alpha.17 — fixed in 7.26.10, 8.0.0-alpha.17
- Npm @Babel/Runtime-Corejs2: before 7.26.10; from 8.0.0-alpha.0 before 8.0.0-alpha.17 — fixed in 7.26.10, 8.0.0-alpha.17
- Npm @Babel/Runtime-Corejs3: before 7.26.10; from 8.0.0-alpha.0 before 8.0.0-alpha.17 — fixed in 7.26.10, 8.0.0-alpha.17
- babel: before 7.26.10; from 8.0.0-alpha.0, < 8.0.0-alpha.17
How to fix
Upgrade to a fixed version: Npm @Babel/Helpers 7.26.10, 8.0.0-alpha.17; Npm @Babel/Runtime 7.26.10, 8.0.0-alpha.17; Npm @Babel/Runtime-Corejs2 7.26.10, 8.0.0-alpha.17; Npm @Babel/Runtime-Corejs3 7.26.10, 8.0.0-alpha.17. Check the vendor advisory for mitigations.
References
- https://github.com/babel/babel/pull/17173
- https://github.com/babel/babel/security/advisories/GHSA-968p-4wvh-cqc8
Get alerted when CVE-2025-27789 or the next vulnerability affects your stack