What’s Vulnerable › Vulnerabilities
CVE-2025-27801: Stored Cross-Site Scripting in Episerver Content Management System (CMS) Media Selection Preview
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser. ContentReference properties, which could be used in the "Edit" section of the CMS, offered an upload functionality for documents. These documents could later be used as displayed content on the page. It was possible to upload SVG files that include malicious JavaScript code that would be executed if a user visited the direct URL of the preview image. Attackers needed at least the role "WebEditor" in order to exploit this issue. Affected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)
Affected products
- Optimizely Episerver Content Management System (CMS): from 11.x before 11.21.4; from 12.x before 12.22.1 — fixed in 11.21.4, 12.22.1
How to fix
Upgrade to a fixed version: Optimizely Episerver Content Management System (CMS) 11.21.4, 12.22.1. Check the vendor advisory for mitigations.
References
- https://api.nuget.optimizely.com/packages/episerver.cms.core/11.21.4#
- https://api.nuget.optimizely.com/packages/episerver.cms.core/12.22.1#
- https://r.sec-consult.com/optimizely
- http://seclists.org/fulldisclosure/2025/Aug/18
Get alerted when CVE-2025-27801 or the next vulnerability affects your stack