What’s Vulnerable › Vulnerabilities
CVE-2025-27809
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-1188
Description
Mbed TLS before 2.28.10 and 3.x before 3.6.3, on the client side, accepts servers that have trusted certificates for arbitrary hostnames unless the TLS client application calls mbedtls_ssl_set_hostname.
Affected products
- mbedtls: before 2.28.10 — fixed in 2.28.10
- TrustedFirmware Mbed TLS: from 3.0.0 before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: mbedtls 2.28.10; TrustedFirmware Mbed TLS 3.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/Mbed-TLS/mbedtls/releases
- https://mbed-tls.readthedocs.io/en/latest/security-advisories/mbedtls-security-advisory-2025-03-1/
- https://github.com/Mbed-TLS/mbedtls/issues/466
- https://mastodon.social/@bagder/114219540623402700
Get alerted when CVE-2025-27809 or the next vulnerability affects your stack