What’s Vulnerable › Vulnerabilities
CVE-2025-27821: HDFS native client: Out of bounds write in URI parser of native HDFS client
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Hadoop: from 3.2.0 before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Hadoop 3.4.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/kwjhyyx0wl2z9b0mw0styjk0hhdbyplh
- http://www.openwall.com/lists/oss-security/2026/01/23/7
Get alerted when CVE-2025-27821 or the next vulnerability affects your stack