What’s Vulnerable › Vulnerabilities
CVE-2025-27822
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-07 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in the Masquerade module before 1.x-1.0.1 for Backdrop CMS. It allows people to temporarily switch to another user account. The module provides a "Masquerade as admin" permission to restrict people (who can masquerade) from switching to an account with administrative privileges. This permission is not always honored and may allow non-administrative users to masquerade as an administrator. This vulnerability is mitigated by the fact that an attacker must have a role with the "Masquerade as user" permission.
Affected products
- backdropcms Masquerade: before 1.x-1.0.1 — fixed in 1.x-1.0.1
How to fix
Upgrade to a fixed version: backdropcms Masquerade 1.x-1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27822 or the next vulnerability affects your stack